Requisiti di Sistema - COMSOL Multiphysics® 5.3a

Questi requisiti sono comuni per tutte le piattaforme:

  • Durante l'installazione si consiglia l'attivazione della scheda di rete e una connessione internet.
  • Almeno 1 GB di memoria, ma si consigliano 4 GB o più per core del processore.
  • 1-5 GB di spazio sul disco, a seconda dei prodotti inclusi nella propria licenza e delle opzioni di installazione.
  • Adobe Acrobat® Reader 10.1.9, 11.0.06 o superiori per visualizzare e stampare COMSOL® documentazione in formato PDF.
  • An Intel® or AMD® 64-bit processor based on the Intel® 64 or AMD64 architecture

Per maggiori dettagli informazioni riguardanti l'hardware, si consiglia anche Knowledge Base entry.

Requisiti Sistemi Operativi

In aggiunta ai requisiti dei sistemi operativi sopraelencati, basta collegarsi a Requisiti di Sistema per la Gamma Prodotti di Interfacciamento per verificare i requisiti specifici per CAD Import Module, Design Module e la gamma prodotti LiveLink™.

Windows® macOS Linux®
Sistemi operativi 64-Bit
  • Windows® 10
  • Windows® 8.1
  • Windows® 8
  • Windows® 7
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows Server® 2008 R2
  • Windows HPC Server 2008 R2
macOS 10.9, 10.10, 10.11, and 10.12
  • Debian® 7 and 8
  • Red Hat® Enterprise Linux® 6.9 and 7.3
  • Ubuntu® LTS 14.04 and 16.04
  • OpenSUSE® Leap 42.1 and 42.2

Requisiti di Sistema Specifici per Sistemi Operativi

Linux®
  • GNU C Library versione 2.7 o superiore1
  • Linux® kernel 2.6.18 o superiore
  • Intel® Pentium® IV o AMD Athlon® XP processor o superiore
  • FlexNet® richiede Linux Standard Base (LSB™)2.

1 Vedere gestore delle licenze FlexNet® su Linux® sotto.

Help di sistema su Linux®

Per far funzionare l\'help di sistema su Linux®, è necessario installare i seguenti pacchetti:

  • Debian® e Ubuntu®: libwebkitgtk-1.0-0
  • RHEL: webkitgtk (non incluso in RHEL7 ma disponibile attraverso EPEL).
  • openSuSE: libwebkitgtk-1.0-0 o libwebkit-1_0-2 a seconda della versione.

Se questi requisiti non vengono soddisfatti, COMSOL si blocca quando si accede all\'help di sistema.

Gestore delle licenze FlexNet®

I requisiti di sistema per il gestore della licenza sono gli stessi di COMSOL Multiphysics. La versione FlexNet® 11.13.1.4 è utilizzata su Windows® e la versione 11.13.1.3 su Linux® and macOS. La versione del servizio lmgrd deve essere allineata o superiore alla versione di FlexNet® usata dal software COMSOL®.

Gestore licenze FlexNet® su Linux®

Linux Standard Base™ (LSB™) è richiesto per Linux® sul computer che funge da server delle licenze.

Se il core package LSB™ è mancante nel repository della distribuzione, creare manualmente un collegamento simbolico, con l\'utente root: ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

Distribuzione Pacchetti richiesti
Debian® lsb-core
Ubuntu® lsb-core
Red Hat® redhat-lsb
SUSE® lsb

Application Builder

L\'Application Builder è supportato dal sistema operativo Windows®.

Requisiti di sistema per parallelismo

Windows® macOS Linux®
Parallelismo Memoria Condivisa Tutte le versioni supportate di Windows® Tutte le versioni supportate di Mac OS X Tutte le distribuzioni Linux® supportate
Parallelismo Memoria Distribuita
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows HPC Server 2008 R2
Non Supportato
  • Red Hat® Enterprise Linux® 6.9 e 7.3
  • Debian® 7 e 8
  • Ubuntu® LTS 14.04 e 16.04

Tutti i computer all\'interno del cluster devono avere la stessa versione Linux® e dovrebbero avere hardware simili. Si consiglia di aver installato OpenFabrics Enterprise Distribution (OFED) 1.5.4.1 o superiore. Se si utilizza un RDMA-capable network fabrics è necessaria una appropriata versione driver o libreria DAPL 1.2 o superiore. Il software è solitamente incluso nel vostro hardware.

La versione 5.3 di COMSOL Multiphysics® è stata validata su sistemi compatibili con la Intel® Scalable System Framework Reference Architecture. La versione 5.3a verrà sottoposta alla validazione a breve e si prevede che la otterrà. Per informazioni su come eseguire COMSOL Multiphysics® e COMSOL Server™ su cloud, visionare eseguire COMSOL su cloud.

Compilatori ufficialmente supportati
Windows® macOS Linux®
Funzione Esterna C Visual Studio® 2010 Intel® Composer XE 2013.3 (conosciuto anche come Intel® Compiler versione 13.0.2) come GCC 4.2.1 ufficialmente supportato Intel® Composer XE 2013.4 (conosciuto anche come Intel® Compiler versione 13.1.2) come GCC 4.2.1 ufficialmente supportato
Java® API JDK 1.7 o inferiore JDK 1.6 1.6, 1.7 o 1.7 1.8 JDK 1.7 o inferiore
COMSOL Multiphysics® è costruito e testato con compilatori C/C++ sopra indicati. Considerare cortesemente che versioni successive dei compilatori C/C++ potrebbero anche essere compatibili con le interfacce esterne C. Quando si utilizza COMSOL API con Java® API nella modalità client/server per i file jar elencati in <installation dir>/bin/comsolclientpath.txt, sono supportati JRE 1.6, JRE 1.7, e JRE 1.8. Quando si utilizza COMSOL API con Java® API nella modalità standalone per i file jar elencati in <installation dir>/bin/comsolpath.txt, è supportato JRE 1.8.

Requisiti di Sistema per la Grafica

COMSOL consiglia rendering hardware per motivi di prestazioni. Rendering hardware richiede driver che supportino OpenGL versione 2.0. Gli utenti Windows® possono anche utilizzare DirectX® versione 9 sulla console locale. Rendering hardware richiede almeno grafica a colori a 24 bit.

AMD®

Modello Scheda Sistema Operativo Versione Driver
Radeon™ Pro WX 5100 Windows® 10 17.Q4-Oct25
Radeon™ Pro WX 4100 Windows® 10 17.Q4-Oct25
Radeon™ Pro WX 4100 Windows® 7 17.Q4-Oct25
Radeon™ Pro WX 3100 Windows® Server 2016 17.Q4-Oct25
Radeon™ Pro WX 2100 Windows® 7 17.Q4-Oct25
FirePro™ W7100 Windows® 10 17.Q4-Oct25
FirePro™ W5100 Windows® 8.1 17.Q4-Oct25
FirePro™ W4100 Windows® 10 17.Q4-Oct25
FirePro™ W2100 Windows® 10 17.Q4-Oct25

NVIDIA®

Modello Scheda Sistema Operativo Versione Driver
NVIDIA Quadro® P600 Windows® 7 385.90
NVIDIA Quadro® M2000 Windows® 10 385.90
NVIDIA Quadro® K2200 Windows® 7 385.90
NVIDIA Quadro® K1200 Windows® 10 385.90
NVIDIA Quadro® K620 Windows® 10 385.90
NVIDIA Quadro® K620 Windows® 7 385.90
NVIDIA Quadro® K620 Windows® 8.1 385.90
NVIDIA Quadro® K620 Debian® 9 384.98
NVIDIA Quadro® K600 Windows® 10 385.90
NVIDIA Quadro® K600 Debian® 8 384.98
NVIDIA Quadro® K600 Red Hat® Enterprise Linux 7 348.98
NVIDIA Quadro® K5000 Windows® 7 385.90
NVIDIA Quadro® K4000 Windows® 7 385.90
NVIDIA Quadro® K2000 Windows® 7 385.90

Le schede grafiche elencate sopra sono state rigorosamente testate per la compatibilità con COMSOL Multiphysics®. Tuttavia si prega di notare che anche altre schede grafiche AMD® o NVIDIA® possono risultare compatibili con COMSOL Multiphysics®. Modelli di schede grafiche che appartengono alla stessa serie di una delle schede elencate sopra hanno maggiori probabilità di essere compatibili con COMSOL Multiphysics®.

Per l'accelerazione hardware su Linux®, utilizzare i driver proprietari forniti dal produttore della scheda grafica, come NVIDIA®, altrimenti utilizzare COMSOL® rendering software. Il driver video Nouveau è supportato solo per il rendering software.

3Dconnexion® SpaceMouse® Devices

3Dconnexion® SpaceMouse® Devices is supported for COMSOL Multiphysics® in Windows® only. Make sure to download the latest drivers from 3Dconnexion.

NOTA: Queste informazioni vengono fornite a vostro beneficio, ma non dovrebbero sostituire un proprio studio dei requisiti di sistema che possono essere appropriati per l'uso personale del software COMSOL® o di altri software, date anche le proprie particolari esigenze. I sistemi e l'hardware si modificano regolarmente, il che può avere un impatto sulla determinazione di quali requisiti di sistema sono appropriati per voi.

Adobe and Acrobat are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries. AMD, AMD Athlon, FirePro, and Radeon are trademarks or registered trademarks of Advanced Micro Devices, Inc. Debian is a registered trademark of Software in the Public Interest, Inc. in the United States. FlexNet is a registered trademark of Flexera Software LLC. GeForce, NVIDIA Quadro, and NVS are trademarks and/or registered trademarks of NVIDIA Corporation in the U.S. and/or other countries. Intel and Pentium are trademarks of Intel Corporation or its subsidiaries in the U.S. and/or other countries. Oracle and Java are registered trademarks of Oracle and/or its affiliates. Red Hat and Red Hat Enterprise Linux are registered trademarks of Red Hat, Inc. Ubuntu is a registered trademark of Canonical Ltd. OpenGL is a trademark or registered trademark of Silicon Graphics, Inc. in the United States and/or other countries worldwide. OpenSUSE and SUSE are registered trademarks of SUSE LLC. Linux, Linux Standard Base, and LSB are trademarks or registered trademarks of Linus Torvalds in the U.S. and other countries. macOS is a trademark of Apple Inc., in the U.S. and other countries. Microsoft, DirectX, Visual Studio, Windows, and Windows Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. COMSOL AB and its subsidiaries and products are not affiliated with, endorsed by, sponsored by, or supported by these trademark owners.